Gelöst [EEEPC] [R105D] Win7 : Touchpad Problem / Hardware-ID

16 Nov 2016 15:14 - 28 Dez 2016 15:17 #1 von smb
Hallo,
ich habe mich hier registriert in der Hoffnung Hilfe zu finden in Bezug auf ein Problem mit dem Touchpad eines Netbooks.

Ich habe zwei AsusEEE R105D. Beide haben von Haus aus Win7 Starter und sind vermeintlich baugleich. Ich nutze die Netbooks eigentlich nur als BackupPC wenn ich auch eine Tatstatur brauche. Trotzdem wollte ich auf beiden Netbooks das System mal frisch aufsetzen, ist ja auch bekannt dass gerade Win7-Systeme mit der Zeit arg langsam werden und sich das Win-Verzeichnis aufbläht.

Ich habe also bei Netbook 1 Win7 Ultimate installiert und ziemlich gleich nach der Installation bemerkte ich, dass das Touchpad nur sehr rudimentär funktioniert, nur Klick, kein Scroll u.ä.
Auf der Asus Support-Seite zum r105d gibt es verschiedene Treiber. Der Synaptics Treiber lässt sich nicht installieren, die Elan-Treiber lassen sich ohne Problem installieren. Aber: Es geht nur ein Klick, kein Scroll und andere Funktionen.

Ich habe also auf meinem baugleichen Netbook 2 mal geschaut welche Software installiert ist, welcher Treiber und welche Dateien in welcher Version installiert sind, und habe sie auf Netbook 1 kopiert (bzw installiert beim Treiber).

Leider ohne Erfolg. Der gleiche Treiber und die gleichen Dateien im Konfigurationsprogramm und der Systemsteuerungsanwendung, die das vierte Elan-Tab in das Maus-Menü bringt, bringen ein anderes Ergebnis. Nur Klick, kein Scroll.

Eine tiefere Suche ergab dann noch Folgendes:
Auf dem funktionierenden Netbook 2 hat die Elan-Anwendung auf der linken Seite etliche Konfigurationsmöglichkeiten. Auf Netbook 1 zeigt mir die gleiche Anwendung, gleiche Version, nur zwei Punkte, Copyright und Klick-Einstellungen.

In der Systemsteuerung steht bei dem funktionierenden Netbook 2 "Elan PS/2 Smart Pad". Bei dem nicht funktionierendem Netbook 1 steht "Elan PS/2 Touch Pad".

In dem Tab "Elan" unter Systemsteuerung -> Maus ist bei dem nicht funktionierendem Netbook 1 das Feld "Optionen" ausgegraut und es steht als Gerät "Standard PS/2 Maus". Bei dem funktionierendem Netbook 2 kann man in die Optionen gehen und es steht auch "Elan PS/2 Smart Pad" da.

Und, zu guter Letzt, die Hardware-ID des funktionierenden Touchpads von Netbook 2 ist "ETD0100". Das nicht funktionierende hat erstaunlicherweise "SYN0A13".

Ich glaube also, dass der Treiber die zur Verfügung stehenden Konfigurations- und Nutzungsmöglichkeiten je nach verwendeter Hardware anbietet, denn die Treiber- und Programmdateien sind aufs Byte gleich. Weil das nicht funktionierende Touchpad sich als SYN0A13 zu erkennen gibt, werden nur die zur Verfügung stehenden Optionen angeboten?
Tatsächlich scheint ja aber SYN0A13 zu dem Synaptics Touchpad zu gehören. Ich habe natürlich versucht, den Synaptics Treiber zu installieren, das ist aber nicht möglich (bricht während der Install ab).

Ich habe, Win7 war ja sowieso grad neu, testweise wieder das Win7 Starter installiert um auszuschliessen, dass Win7 Ultimate schuld ist. Aber das brachte keine Änderung am Problem.

Ich habe auch versucht (Systemsteuerung -> Geräte-Manager -> Mäuse u.a. Zeigegeräte -> Treiber - > Treiber aktualisieren -> Vom Computer auswählen -> kompatible Hardware) zu DEaktivieren, dann wurde mir auch ein Elan *Smart* Pad als Installationoption angezeigt. Die Treiberinstallation lässt sich auch erzwingen, bringt aber keine Änderung.

Hm... ich habe natürlich vor der Neuinstallation nicht die Hardware-IDs notiert ;) Aber ich denke schon, dass es ein Elan Touchpad ist, und kein Synaptics. Es lässt sich ja auch kein Treiber von Synaptics installieren.
Wo kommt denn die Hardware-ID her? Ich hätte vermutet aus einen Rom-Chip der Hardware, aber jetzt vermute ich eher, dass die Probleme aus einer falschen Hardware-ID resultieren, die dem Touchpad zugewiesen wurde? Gibt es sowas überhaupt?

Letztendlich sei erwähnt, das Touchpad funktionierte natürlich einwandfrei bis zur Neuinstallation.

Bin für jede Hilfe dankbar :)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

16 Nov 2016 18:32 #2 von Falck
Hallo,

ein Versuch.
Bitte deinstalliere noch einmal den vorhandenen Touchpadtreiber.
Der unten angehängte Treiber enthält die Hardware_ID zu deinem Touchpad, sollte somit passen.
Vorher auch mal bitte schauen was passiert wenn du im Abgesicherten Modus (beim Einschalten F8 immer wieder drücken bis du im Menü bist) startest.

dlcdnet.asus.com/pub/ASUS/EeePC/Driver/Synaptics_v14_0_16.zip

Falck

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

17 Nov 2016 16:54 - 17 Nov 2016 16:59 #3 von smb
Hi Falck,

erstaunlicherweise funktioniert es! :)

Nun frage ich mich natürlich, warum sich die gleiche Version von der Asus-Support-Seite ( www.asus.com/de/supportonly/Eee%20PC%20R105D/HelpDesk_Download/ ) des r105d nicht installieren lässt? Ich habe doch unter Anderem auch den Synaptics Treiber getestet wegen der ID...

Link von der r105d-Seite:
dlcdnet.asus.com/pub/ASUS/EeePC/1001PXD_...naptics_WinXP_Win7_Z140160.zip

Dein Link:
dlcdnet.asus.com/pub/ASUS/EeePC/Driver/Synaptics_v14_0_16.zip

Release-Notes beider Treiber: Version 14.0.16 11/19/2009 (WinXP/Vista/Win7)

Ich habe beide Treiber verglichen, sie haben scheinbar gleichen Dateigrößen und -versionen, aber: Der Treiber der r105d-Seite scheint nicht signiert zu sein. Siehe Screens, die nicht signierten .exe zeigen auch kein Symbol. Auch bei Byteweiser Vergleich zeigt mir die .exes als unterschiedlich an.


Leider klappte das Einbinden der Bilder nicht, daher als Link...

Bild 1: www.imagebam.com/image/6346dc515344069
Bild 2: www.imagebam.com/image/5e0e86515346488

Damit hätte ich wirklich nicht gerechnet und du wenn nicht eine andere Quelle des vermeintlich gleichen Treibers gehabt hättest, wären wir vermutlich auch nicht darauf gekommen.

Danke :)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

17 Nov 2016 21:04 - 17 Nov 2016 21:05 #4 von Falck
Ist doch super das es funktioniert hat!:laugh:
Woran es liegt kann ich dir nicht genau sagen, nur soviel, wenn ich deine verlinkte Datei herunter lade sieht sie anders aus wie dein gepostetes Bild.
Sieht genau so aus wie meine.
Vielleicht war dein Download korrupt?
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Powered by Kunena Forum